[PHP-dev 1550] PHPが、FreeBSD-10でコンパイル不能な件

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[PHP-dev 1550] PHPが、FreeBSD-10でコンパイル不能な件

Tomoyuki Asakawa
他力本願の浅川です。

FreeBSD 10になって、PHPがソースからコンパイルできなくなりました。
Portsの方は対策されていてコンパイルできるのですが
オリジナルの方は、最新のphp-5.5.13でも修正されてない模様です。

原因は下記のMLから引用します。

> [FreeBSD-users-jp 95150] Re: FreeBSD 10.0-RELEASEで共有ライブラリが生成されない
>
>
> 古い autotools を使って生成した configure などのファイルは、
> FreeBSD の 2 桁のリリース番号を正しく認識しません。
> 具体的には、次のファイルについて freebsd1* を freebsd1.* に
> 書き換える必要があります。
>
> aclocal.m4
> acinclude.m4
> config.libpath
> config.rpath
> configure
> ltconfig
> libtool.m4
> libtool
>
> ports に含まれるソフトウェアは、構築前にこの書き換えが
> 自動的に行われます。基本的には、ソフトウェア配布元が修正しないと
> 解決しない問題です。
_______________________________________________
PHP-dev mailing list
[hidden email]
http://ml.php.gr.jp/mailman/listinfo/php-dev
Loading...