[PHP-users 35776] phpの設定の問い合わせ

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[PHP-users 35776] phpの設定の問い合わせ

gigi_3762
初めて投稿します。PHP素人です。
先日、お客様のサーバにウイルスバスタをアップグレードしたところお客様のPHPが動かなくなりました。メーカーに確認したら、管理プログラムにPHPを利用している為、バッテングしたようです。
お客様の旧環境はWindows2003にPHP2.5.1とApacheで動作してましたが、ウイルスバスタをアップグレードしたら、PHP2.5.13がインストールされ元のPHP2.5.1も残っているが、Apacheがphp2.5.13を見に行っているようです。
php2.5.13を削除してphp2.5.1の元の環境に戻すにはどの様にすればいいか教えて下さい。
_______________________________________________
PHP-users mailing list  [hidden email]
http://ml.php.gr.jp/mailman/listinfo/php-users
PHP初心者のためのページ - 質問する前にはこちらをお読みください
http://oldwww.php.gr.jp/php/novice.php3
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[PHP-users 35777] Re: phpの設定の問い合わせ

Cocoa
はじめまして

まずは現在Apacheが見に行っているphpのバージョン確認をして下さい。

apacheのhtdocsフォルダ以下に

<?php
phpinfo();
?>

というphpスクリプトを書いて適当な名前で保存し、ブラウザから実行すると、phpのバージョン情報が表示されます。

次にapacheのconfフォルダのhttp.confファイルを見ます。

普通はここに
PHPIniDir というコードがあってそこでapacheが見に行くphpのフォルダを指定しているのですが、、、確認していただけますか?


from my iPhone

On 2013/06/23, at 18:16, [hidden email] wrote:

> 初めて投稿します。PHP素人です。
> 先日、お客様のサーバにウイルスバスタをアップグレードしたところお客様のPHPが動かなくなりました。メーカーに確認したら、管理プログラムにPHPを利用している為、バッテングしたようです。
> お客様の旧環境はWindows2003にPHP2.5.1とApacheで動作してましたが、ウイルスバスタをアップグレードしたら、PHP2.5.13がインストールされ元のPHP2.5.1も残っているが、Apacheがphp2.5.13を見に行っているようです。
> php2.5.13を削除してphp2.5.1の元の環境に戻すにはどの様にすればいいか教えて下さい。
> _______________________________________________
> PHP-users mailing list  [hidden email]
> http://ml.php.gr.jp/mailman/listinfo/php-users
> PHP初心者のためのページ - 質問する前にはこちらをお読みください
> http://oldwww.php.gr.jp/php/novice.php3
_______________________________________________
PHP-users mailing list  [hidden email]
http://ml.php.gr.jp/mailman/listinfo/php-users
PHP初心者のためのページ - 質問する前にはこちらをお読みください
http://oldwww.php.gr.jp/php/novice.php3
Loading...