[PHP-users 35797] php-5.3.3-14.el6のconfigureオプションの変更について

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[PHP-users 35797] php-5.3.3-14.el6のconfigureオプションの変更について

SaitoTetsuya
皆様

初めまして
斉藤といいます

この度、centos6.5にてyumを用いて、phpをinstallしました
しかし、yumでinstallしたパッケージではmime-magicが組み込まれていなかったので
php-5.3.3-27.el6_5.src.rpmをinstallして、
# Build /usr/bin/php-cgi with the CGI SAPI, and all the shared extensionsの
pushd build-cgiのbuildオプションに
--with-mime-magic=%{_datadir}/file/magic.mime
を追加して、rpmbuildを実行してrpmの再作成をして
作成出来たrpmを再インストールして
php -mを実行して組み込まれたモジュールの確認をしたのですが
mime.magicが有効になっていない状況です

これは私が実施をしたrpmbuildの操作が間違っているからなのでしょうか

識者の皆様、ご指導をお願いします

斉藤 哲也
_______________________________________________
PHP-users mailing list  [hidden email]
http://ml.php.gr.jp/mailman/listinfo/php-users
PHP初心者のためのページ - 質問する前にはこちらをお読みください
http://oldwww.php.gr.jp/php/novice.php3
Reply | Threaded
Open this post in threaded view
|

[PHP-users 35798] Re: php-5.3.3-14.el6のconfigureオプションの変更について

HOTTA Michihide
堀田です。

# 複数MLへのマルチポストは極力やめてください。今後はこちらで。

http://www.php.net/manual/ja/mime-magic.installation.php

> Mimetype 拡張モジュールは PHP 5.3.0 で削除されました。後継は Fileinfo です。

mime-magic がないことで具体的にどんな不具合が出ているかを
書いていただけると、もう少し何かわかるかもしれません。また、

http://www.iimc.kyoto-u.ac.jp/ja/services/ismo/whatsnew/security/detail/03934.html

php 5.3 はもうすぐサポート終わりますよーというのもあるので、特に
外向けに公開するサービスの場合は、新規インストールするなら
可能であれば 5.4 / 5.5 を検討されたほうがいいかもしれません。
(半分は自分に向けて言ってますw

ちなみに私は CentOS 6.5 のテストサイトではこれでやってます:
http://net-newbie.com/cakephp/install/

2014年1月12日 18:08 SaitoTetsuya <[hidden email]>:

> 皆様
>
> 初めまして
> 斉藤といいます
>
> この度、centos6.5にてyumを用いて、phpをinstallしました
> しかし、yumでinstallしたパッケージでは mime-magicが組み込まれていなかったので
> php-5.3.3-27.el6_5.src.rpmをinstallして、
> # Build /usr/bin/php-cgi with the CGI SAPI, and all the shared extensionsの
> pushd build-cgiのbuildオプションに
> --with-mime-magic=%{_datadir}/file/magic.mime
> を追加して、rpmbuildを実行してrpmの再作成をして
> 作成出来たrpmを再インストールして
> php -mを実行して組み込まれたモジュールの確認をしたのですが
> mime.magicが有効になっていない状況です
>
> これは私が実施をしたrpmbuildの操作が間違っているからなのでしょうか
>
> 識者の皆様、ご指導をお願いします
>
> 斉藤 哲也
> _______________________________________________
> PHP-users mailing list  [hidden email]
> http://ml.php.gr.jp/mailman/listinfo/php-users
> PHP初心者のためのページ - 質問する前にはこちらをお読みください
> http://oldwww.php.gr.jp/php/novice.php3



--
HOTTA Michihide <[hidden email]>
_______________________________________________
PHP-users mailing list  [hidden email]
http://ml.php.gr.jp/mailman/listinfo/php-users
PHP初心者のためのページ - 質問する前にはこちらをお読みください
http://oldwww.php.gr.jp/php/novice.php3